WWW関係のリソース [WWW]

-- WWW isn't technically new. Application of,is.

HTML,SGML,HTTPなどについて。
あいにくここには HTML入門のたぐいは(まだ)置いてありません :P

$Id: index.html,v 1.21 2022-03-25 19:24:42+09 kabe Exp $


◆ 自筆アーカイブ

▼CGIのメカニズムについて
CGIがどういう風にして起動されるのか、 自分なりにまとめたものです。
▼User-Agentについてのたわごと
(古いのて注意) サーバーの統計情報を解析している 時に書き貯めていったものです。 いや世の中には変なAgentもあるもんですなぁ
▼帰ってきたUser-Agentについてのたわごと
2018頃から再度書き足していっているものです。 あまり更新頻度は高くないので注意。
▼非標準HTTPヘッダ一覧
標準になっているようなものは載せていません。
▼ブラウザの HTTP Request を見てみる
つついてみてください。あなたのブラウザが、どういった形式で httpdに要求を出しているかがわかります。
Requestに対しHTTPサーバーがどう答えるかは telnetすれば分かるんですが、ブラウザ自身の Requestは こういった方法か、 HTTP/1.1の TRACEメソッドでも 使わないと見ることはできません。
(Proxyなどを通している場合は、ブラウザ自身ではなく、 当サーバーに一番近いエンティティの Requestが返ります。)
▼ブラウザの HTTP Request を見てみる
上のものがうまく動かない場合は、 こちらのmod_echoserver を使ったものを試してみてください。 (同じヘッダを複数回渡してくる場合は、Apache側でカンマ区切りで ひとまとめにされてしまいますが)
▼ブラウザの HTTP Request を見てみる(rot13版)
User-Agent が見えるページを返すと ペナルティを科す検索エンジン用。 効果のほどは不明。

◆ 基本

▼WWWコンソーシアム
CERNの分身。WWWに関する規格の総元締め。 W3C httpd,Arenaブラウザ、libwwwなども作っています。
HTML3.2が出てから、表紙ページが見づらくなりました。
▼HTML 2.0
現行のHTMLの基本です。初心者向けに書かれているわけではないので、 ある程度HTMLを理解してからとりかかるのが良いでしょう。
RFCのほうはベタテキストですが、こっちはHTMLバージョンです。
▼HTTP 1.0
サーバーやクライアントを書く人でなければ参照することは 少ないとは思いますが… おっとCGIを書く場合は知っておいた方がいいですね。 <META HTTP-EQUIV> を きちょうめんに書く人も参照しましょう。
目次がハイパーリンク化されている点がRFC版と違います。
▼Universal Resource Identifiers
RFC1630(URI)のもととなっている(と思われる…)ドキュメント。 HTMLです。
▼Uniform Resource Locators
RFC1738(URL)はこれから生成されています。HTML。

◆ CGIなもの

▼deFactoStandard CGI/1.1
「CGIのデファクトスタンダードを定める試み」と書かれています。 中身は下のNCSAのドキュメントをまとめたものです。
▼NCSA CGI/1.1
Common Gateway Interface (CGI)。CGIはNCSAが最初に作り、 これが一般に広まったみたいですね。
▼CGI FAQ集 (M.Hedlund) .
地味ですし、建設中らしいですが良くまとまっており、 初心者から上級者までだれでも参考になることが書かれています。 一度のぞくと良いでしょう。
▼CGIのメカニズムについて
CGIがどういう風にして起動されるのか、 自分なりにまとめたものです。

◆ SGMLなもの

▼SGML Web Page (www.sil.org) .
ちょっと大きめのアーカイブ。有用なリンク多数あります。 ここからはじめるのもいいかも。
▼SGML Open
SGML普及・標準化団体。Webですべての情報が入手できる わけではないことが分かります。 (規格は買うもんである)

▼やさしいSGML入門 (www.brainlink.com)
そんなに大きくありませんが、なかなか気合いはいってますねぇ。 初めて読むには手頃な大きさです。
▼SGMLとはなんぞや(日本語版)
エクスター大学のプロジェクトで 使われたというチラシ。 英語特有の「熱さ」があるので、勢いで翻訳しちゃいました。

▼SP
James Clarkの SGML パーサ。 sgmlsの上位バージョン。 パーサの中では一番有名なものだと思われる。 コンパイルにはC++が必要(g++でもOK)。 SP (nsgmls) は単独ではあまり役に立たないので、 この出力をさらに加工するようなものと組み合わせて使う。 CoSTやSGMLS.pmが有名。
▼CoST Home Page
sgmlsと組み合わせて使うSGML加工ツール。 プログラミングは Tcl で行なう。 [サンプルスクリプト]
▼SGMLS.pm
sgmlsと組み合わせて使うSGML加工ツール。perl5を使用。 [サンプルスクリプト]

sgmlspl というサンプルプログラムもついてきます。 [サンプルスクリプト]

▼perlSGML
PerlでSGMLを処理するためのライブラリ集。
▼SoftQuad HTML & SGML Resource (www.sq.com)
「もっとHTMLとSGMLについて知りたい人たちのための」ページ。 企業のページなので出版物の宣伝なんかも入ってますが、 基本的なリンクは揃っています。

◆ HTMLなもの

▼HTML 2.0 (www.w3.org)
まずは基本からでしょう。
▼HTML 3.0 Draft (期限切れ)
ドラフト段階のまま、expireしてしまいました。 HTML3.2 に置き換わったということになってますが、 その精神は結局受け継がれることはありませんでした。
▼HTML 3.2
まだ良く読んでませんが、処理を示すタグが大幅増強されて いるようですね。予想されたことではありますが…
▼HTML2.0のNetscape拡張 (home.netscape.com)
なんだかんだいっても、Netscapeの拡張はユーザー数や自由度の点で 無視できません。DTDを書かないのはDTDで書けない (SGMLに準拠してない)という事情があるようです。
▼HTML3.0のNetscape拡張 (home.netscape.com)
同上。でもホームページくらいMosaicでも ちゃんと見えるようにしておいて欲しいよな。

▼HTML2.0 DTDの構造概観 と ツリー図 (www.oac.uci.edu)
dtd2htmlで HTML2.0 DTDを変換し、 構造をブラウズできるようにしたものです。おすすめ。
▼HTML 3.2 DTD 構造概観(Wilbur) (Cougar)
同上、ただし HTML 3.2 のもの。 くれぐれもこれを参考にして汚いドキュメントを書かないように。
▼「HTML重箱の隅」と 「ブラウザにありがちなバグ」 (Mike W.Meyer)
好きですこういうの。あなたのブラウザは大丈夫ですか?
▼行儀の悪いHTML (www.earth.com) .
礼儀正しいHTMLを書くにはどうしたらよいか?

◆ 歴史

▼CERN (Conseil Europeen pour la Recerche Nucleaire)
WWWの発祥地。WWW自体のことはおおかた WWW Consortiumに移り、 今は本来の素粒子研究所のページに戻っています。
▼NCSA HTTPd
イリノイ大学のスーパーコンピューティング部 (NCSA)が開発した HTTPサーバー。高機能サーバーのはしりですかね。

◆ 関係RFC

すべてftp.tohoku.ac.jpへのリンクです。 大きめのものばかりですので、遠方の方はまず近場を漁ってみましょう。
・RFC1630 (57K)
Universal Resource Identifiers (URI)について。
・RFC1738 (51K)
Uniform Resource Locators (URL)について。
・RFC1808 (35K)
Relative URL,簡単にいえば、頭に"http:"とかが ついていないURLについて。 また、HREF="..."に書かれたURLの解釈方法についても 述べられています。
・RFC1866 (147K)
Hyper Text Markup Language (HTML)2.0。 これもRFCになったんですねぇ。 そのうちISOにもなりそうな勢いです。
・RFC1945 (134K)
Hypertext Transfer Protocol (HTTP)1.0。 RFCが遅くなったのにもいろいろわけがありそうです。
・RFC1521(183K)
・RFC1522(21K)
MIME (Multipurpose Internet Mail Extensions)。 HTMLは"text/html"というMIMEのContent Typeとして登録されています。

ホームページへもどる
かべ@sra-tohoku.co.jp